📦 TypeError: this.getOptions is not a function
作成日: 2021/03/26
2

しばらくパッケージ更新してないなーと思い、ncu -u したら sass-loader のメジャーバージョンが11になった。
パッケージインストールして npm run serve しようとしたら sass-loader が原因でタイトルのエラーが出てビルドに失敗した。
タイトルのエラーで検索したらドンピシャの記事があった。
D_Painさんが言うにはsass-loaderの11はvue2.6に対応してないらしい。
というわけで、sass-loader@10.1.1 をバージョン指定でインストールした。
ついでに .ncurc.yamlsass-loader を追加した。
パッケージインストールして npm run serve したら今度はビルドに成功した。

ねこなのかうまなのか